C# と VB.NET の質問掲示板

ASP.NET、C++/CLI、Java 何でもどうぞ

C# と VB.NET の入門サイト

Wordpressへの投稿

[トピック内 5 記事 (1 - 5 表示)]  << 0 >>

■85741 / inTopicNo.1)  Wordpressへの投稿
  
□投稿者/ nobichan (1回)-(2017/11/18(Sat) 23:05:24)

分類:[C#] 

C#で簡単にWordpressに投稿するには、Windows10の場合、何を使ったら良いでしょうか?
XML-RPC.NETのサイトが無くなってたり、xml-rpc.net.2.5.0.zipを手に入れてみても、.NETFramework4だと使えないようで、
.NETFramework3.5などインストールしようとしてもWindows10ではインストールできないとか、
いろいろ環境を変えてまで使うより、Windows10の状態で使えるものが無いものでしょうか?

引用返信 編集キー/
■85742 / inTopicNo.2)  Re[1]: Wordpressへの投稿
□投稿者/ WebSurfer (1355回)-(2017/11/19(Sun) 09:50:17)
No85741 (nobichan さん) に返信

> .NETFramework3.5などインストールしようとしてもWindows10ではインストールできないとか、

実際自分は Windows 10 Pro 64-bit に .NET 3.5 をインストールして使っています。.NET 3.5
を使えれば目的が果たせるなら Windows 10 に .NET 3.5 をインストールすることを検討しては
いかがですか?

ところで、投稿する先の WordPress のサイトは質問者さんご自身のサイトですか? もし、そう
でない場合は、そのサイトの管理者に許可は得ているでしょうか?
引用返信 編集キー/
■85743 / inTopicNo.3)  Re[2]: Wordpressへの投稿
□投稿者/ nobichan (2回)-(2017/11/19(Sun) 10:43:30)
ありがとうございます。
自分のサイトです。
.NET3.5のインストールをやってみたのですが、実行がされません。
「Windowsの機能の有効化または無効化」の.NET3.5の項目にはチェックが入っていたのですが。
インストールするために他に行うことはあるでしょうか?
引用返信 編集キー/
■85744 / inTopicNo.4)  Re[3]: Wordpressへの投稿
□投稿者/ nobichan (3回)-(2017/11/19(Sun) 10:59:17)
警告 1 現在のターゲット フレームワーク ".NETFramework,Version=v4.0,Profile=Client" 内に、参照アセンブリ "CookComputing.XmlRpcV2" が依存する "System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" が含まれていません。このため、参照アセンブリを解決できませんでした。これを修正するには、次のいずれかを行ってください。(1) このプロジェクトのターゲット フレームワークを変更する。(2) 参照アセンブリをプロジェクトから削除する。 wfp_av-mu

ちなみに、上記のエラーが出て、CookComputing.XmlRpcV2.dllの参照が消されてしまいます。

引用返信 編集キー/
■85745 / inTopicNo.5)  Re[4]: Wordpressへの投稿
□投稿者/ nobichan (4回)-(2017/11/19(Sun) 11:38:39)
お騒がせして申し訳けありません。
.NETFramework3.5はインストールされていて、有効で、プロジェクトのプロパティで.NETFramework3.5を対象のフレームワークとして選択するだけでした。
調べが足りませんでした。
ありがとうございました。
解決済み
引用返信 編集キー/

このトピックをツリーで一括表示


トピック内ページ移動 / << 0 >>

このトピックに書きこむ