C# と VB.NET の質問掲示板

わんくま同盟

ASP.NET、C++/CLI、Java 何でもどうぞ

C# と VB.NET の入門サイト

ツリー一括表示

ASP.NETが動作しない /LL (18/06/22(Fri) 11:16) #87712
Re[1]: ASP.NETが動作しない /LL (18/06/22(Fri) 11:52) #87713 解決済み


親記事 / ▼[ 87713 ]
■87712 / 親階層)  ASP.NETが動作しない
□投稿者/ LL (1回)-(2018/06/22(Fri) 11:16:02)

分類:[ASP.NET (C#)] 

初めて利用するため、マナー違反等ありましたら、ご指摘ください。

VisualStudioにて、とあるイントラ向けウェブページをASP.NETで作成し、社内のWindowsサーバで動作させようとしたところ、動作しません。
現象としては、当該のaspxファイルにあるタグをそのまま表示している状態です。
VisualStudio上でのデバッグ実行では、当該プログラムは問題なく動作しています。

環境
サーバOS:Windows Server 2016(バージョン1607 OSビルド 14393.1480)
IISバージョン:10.0.14.14393.0
プロセッサ:Intel(R) Zeon(R) CPU E5-2650L v2 @ 1.70Ghz 1.70Ghz
メモリ:6.00GB

対象サイト
1画面のみ
VisualStudio2015で作成。
初期設定はASP.NET Webアプリケーション⇒ASP.NET 4.5.2テンプレート(Empty)を選択。

リリース方法
・発行を選択
 Publis method:WEb Deploy Package
これで、Deploy用のZipファイルを生成

IISへの登録
 web Deployツールを以下から導入
 https://www.microsoft.com/ja-jp/download/details.aspx?id=39277
 選択したのはADM(上)のほう

 その上で、IIS上で以下の通り操作。
 サイト⇒Default Web Site⇒(右クリック)展開⇒アプリケーションのインポート⇒上記Zipファイル選択
 『パッケージ内容の選択』は全チェック有効
 これで設定が追加されました。
 しかし、当該ファイル(*****.aspx)にアクセスしても、記載されたHTMLタグのみが表示されるだけという状況です。

ただ、同環境でEmptyではなく、MVCを選択して作成した簡易アプリは動作しました。
(そちらはファイルを置いて単にIISでサイト追加しただけ)

何か設定が不足しているのかとは思いますが、色々調べても分かりませんでした。
何か分かることがございましたら、『この設定はどうか?』という僅かな手がかりでもかまいませんので、教えていただけると助かります。

[ □ Tree ] 返信 編集キー/

▲[ 87712 ] / 返信無し
■87713 / 1階層)  Re[1]: ASP.NETが動作しない
□投稿者/ LL (2回)-(2018/06/22(Fri) 11:52:17)
すみません、こちら、自己解決しました。
global.asaxが不足していたのが原因でした。

解決済み
[ 親 87712 / □ Tree ] 返信 編集キー/


管理者用

- Child Tree -