C# と VB.NET の質問掲示板

ASP.NET、C++/CLI、Java 何でもどうぞ

C# と VB.NET の入門サイト

MSIのインストーラでFrameworkの更新が促される

[トピック内 3 記事 (1 - 3 表示)]  << 0 >>

■90630 / inTopicNo.1)  MSIのインストーラでFrameworkの更新が促される
  
□投稿者/ ほぼ素人 (15回)-(2019/03/26(Tue) 21:30:44)

分類:[.NET 全般] 

お世話になっておりmす

VS2017 vb.net で作ったプログラムのインストーラの動作について
必要ないと思われる「.NET Framework 4.6.1」のインストールを要求されてしまいます

動作環境は文末の通りとなります

プログラムのターゲットフレームが「.NET Framework 4」なので
プログラム本体exe単体で起動すれば問題なく動作していますし現在の環境の 4.5.2 でも動作するはずです
これまでは WIN7、WIN8、WIN10 の環境で問題なくインストールできていました

何か原因と思われることはありますでしょうか?



−−−−−−−−−−−−−−−−−−−−−−−
【使用パソコン】
−−−−−−−−−−−−−−−−−−−−−−−
OS:WIN10のダウングレードのWIN7
.NET Framework :4.5.2

−−−−−−−−−−−−−−−−−−−−−−−
【作成プログラム】
−−−−−−−−−−−−−−−−−−−−−−−
ローカルパソコンで使用する簡単な表計算のソフトです
ターゲットフレームワークの設定 : .NET Framework 4

−−−−−−−−−−−−−−−−−−−−−−−
【インストーラの設定】
−−−−−−−−−−−−−−−−−−−−−−−
インストールの右クリックプロパティメニュー内の「prerequisites」 ではインストールしないように設定しています

「必須コンポーネントをインストールするセットアッププログラムを作成する
のチェックははずしています


引用返信 編集キー/
■90634 / inTopicNo.2)  Re[1]: MSIのインストーラでFrameworkの更新が促される
□投稿者/ とっちゃん (582回)-(2019/03/27(Wed) 11:04:48)
No90630 (ほぼ素人 さん) に返信
> −−−−−−−−−−−−−−−−−−−−−−−
> 【インストーラの設定】
> −−−−−−−−−−−−−−−−−−−−−−−
> インストールの右クリックプロパティメニュー内の「prerequisites」 ではインストールしないように設定しています
>
> 「必須コンポーネントをインストールするセットアッププログラムを作成する
> のチェックははずしています
>
>
起動条件(Launch Conditions)の Launch Conditions に、 .NET Framework という要素があると思います。
それを選択してプロパティを表示し、Version が何になってるかを確認してみてください。

デフォルト設定だと、4.6.1 とかだった気がする。
ここを必要とするバージョンに合わせる必要があります。
必須コンポーネントの有無や設定とは一切連動しないので、注意しないといけないところの一つです。

引用返信 編集キー/
■90680 / inTopicNo.3)  Re[2]: MSIのインストーラでFrameworkの更新が促される
□投稿者/ ほぼ素人 (17回)-(2019/04/05(Fri) 20:21:11)
No90634 (とっちゃん さん) に返信

返事が遅くなり大変申し訳ありません
ご記載のようにやってみたところ、うまくいきました
自分で調べても絶対にわからない方法でしたので、とても助かりました
本当にありがとうございました
解決済み
引用返信 編集キー/

このトピックをツリーで一括表示


トピック内ページ移動 / << 0 >>

このトピックに書きこむ